Terrin is still buggy

Rhii’ s power, the spell that lowers mana required by card, causes many times inability to spawn cards. This happens more and more often. It’ s frustrating as i am stuck waiting to lose

Links:

Lot of these bug is solved yet

Thanks for reaching out and sharing the replays, Kariolis!
We’ve released a fix for the Power Rhii spell bug with the latest release on Monday (Nov 4th), so can you please confirm if you’re on the latest Heroic version (1.10.0) and if these replays were recorded after that update? If so, we’d have to look into it in greater detail. Anyways apologies for the inconvenience.
Thanks so much,
Noella

I am on latest version. It happened 3 times today, again. The bug with lagging two continous spells has been fixed, but the one with the stuck summons persists. I can upload more videos if you think it can help

Another video, from today event as proof that i am on latest version and stil happening

Καλά να πάθεις χεχεχε!

Hmm that seems to be a different kind of bug. Thanks a lot for confirming and forwarding the video,we’re looking into the root cause!
In the meantime, could you please share what device you’re playing on (in this thread or in a private message)? It’ll help us with the troubleshooting.
Thanks again and have a great day!
Noella

My device is LeEco Le Max 2. I thought it had to do something with the network, but it does the same think on other networks and mobile data too

1 Like